
MJKZZ Stack and Stitch System User Manual

Version 2.0

Overview

This is MJKZZ Stack and Stitch System controll application version 2.9 

user manual. This application allows you to set up parameters, control 

motors via USB port on a computer running Windows operating system.

Operation

Connecting To Rail

To connec to a rail, make sure the USB cable is plugged in and the USB 

controller is powered up , 

Plugging the USB cable is NOT enough, powering up the USB controller is also 

important as it will allow the controller to communicate with computer.  This 

is where many users make mistake at.

Moving The Rail

Once connection to USB controller is made, it is time to set range for the rail 

to move around and be bounded. To prevent accidental moving the rail out of 

boundary of physical ends, 

Note, there are tabs for each axis, namely X, Y, and Z. The following 

operations can be performed when one of the tabs is selected.

Setting Range - We ultilize a mechanism that prevents this sort of thing: 
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Press and hold the left SHIFT key while moving the rail by press UP or DOWN 

arrow keys to set the RANGE. Without doing this, upon first powering up and 

initial usage, the rail will NOT move because the RANGE is ZERO, it will beep.

Moving Rail - After range is set, press and hold UP or DOWN arrow key will 

move the rail in the desired direction. 

Moving Rail by Full Step - to move the rail up or down by a full step size, use 

Page Up or Page Down key to do so. These two keys will produce precisely a 

full step forward or backward.

Moving Rail to Start or End Position - press LEFT or RIGHT arrow key will 

move the rail to either Start Position or End Position, this is a great way to 

double check both end before start stacking.

Main Screen

Stack Tab
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On this tab, parameters shown here are related to camera and optical 

system, such as sensor width, sensor height, optical magnificatiion, optical 

depth of focus, and overlapping of each frame.

Sensor Width & Sensor Height

These two parameter refer to dimension of camera sensor.  The following is 

a list of sensor sizes:

Full frame camera: 36mm by 24mm

APS-C camera : 22.7mm by 15.13mm

Micro four third camera : 17.3mm by 13mm (note, ration is 4:3)

However, care must be taken with some of the settings in camera. For 

example, some camera allows you to specify aspect ratio when taking a 
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picture. For example, Sony A7 III allows you to specify 16:9 aspect ration, so 

instead of 36mm by 24mm, the actual sensor size is 36mm by 20.5mm. 

Also note that some full frame camera can be set to APS mode, in that case, 

sensor size changes. Again, with Sony A7 III as example, when it is et to APS 

mode, actual sensor size is 23.5mm by 15.7mm (in 3:2 aspect ratio)

Magnification

This is the parameter that specifies actual optical magnification instead of 

nominal magnification labeled on an objective or on an macro lens but with 

extensions added.

The best way to obtain this information is to take a picture of a ruler and 

count number of markers capture, then calculate the real magnification.

Step Size / DOF

This parameter refers to step size when moving the camera (or subject). 

Step size is closely related to and determined by the optical system used. 

For example, if depth of focus of the optical system used is 52um, then it is 

better to set this parameter to 50um.

Frame Overlap

When stitching multiple images to form one signle image, it is better(or a 

must) to capture these images with certain overlap. This parameter 

specifies how much overlap between two frames (both vertical and 

horizontal) when capturing each tiles.

Total Frames

This is a calculated parameter based on settings in X and Y axis and Frame 
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Overlap parameter. It is not editable.

Total Images

This is a calculated parameter based on settings in X ,Y and Z axis and Frame 

Overlap parameter. It is not editable.  Important note, under Z axis, each 

frame can have different start and end positions, thus yielding different 

number of images for that frame.

Estimated Time

This is calculated estimated time to complete whole operation. It should be 

used as reference, not a precise number.

X and Y Axis Tab
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On this tab, you can specify starting and ending position for either X or Y tab 

as well as moving respective rail by using Up, Down, Left, and Right arrow 

keys, or using XBox 360 controller. For more information please refer to 

Moving The Rail section of this document.

Current Pos

This is where current rail position is displayed for either X or Y depending on 

which tab is selected. It is not editable,but moving the rail will change this 

value. Or by pressing buttons on XBox 360 controller, more details in XBox 

360 section.

Start & End Pos

This is the starting and edning position for the selected axis. It can be set by 

pressing the "Set" button next to it. Or it can be set by pressing A (for start 
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position) or B (for end position) on XBox 360 controller. Important note: Start 

position does not have to be less than End position. If Start position is greater 

than the End position, the system moves the rail backwards.

Count

This is number of frames for the selected axis, it is based on start position, 

end position, and Step Size for the selected axis.

Step Size

This is an informational parameter that is based on sensor size and overlap 

percentage. It is not editable.

Distance

This is the distance between start and end position for the selected axis

Z Axis Tab
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This is where parameters for Z axis are specified and displayed. Essentially, 
this is the "stacking" part of Stack and Stitch. It is very import to note that 
parameters for all previous tabs, ie, Stack, X, and Y tabs, must be completely 
specified, otherwise, information on the Z tab will be useless. This is because 
how each cell (frame) is divided and gridded is based on information 
specified in Stack, X and Y tab.

For example, if all information on Z axis are setup, but then, the start position 
of X axis is changed, resulting an extra count for X axis. What this means is 
that cells (frames) specified previously are not correct and must be rectified 
as well. 

When any information on the Stack, X, or Y tab are changed, all parameters 
regarding Z axis will be reset to ZERO. So this is very important as setting up 
Z axis is very tedious.

Cell
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When setting up to stitch multiple images into one final image, each image 
will be divided into different "cells (or frames)".  MJKZZ Stack and Stitch 
system allows different stacking parameters to be specified for each cell. 
This is necessary because at each cell, the start, end positions might be very 
different. For example, an antenna of a bug might stick out from its body and 
is very thin in terms of depth, to capture this part of body, it is better to only 
specify stacking parameters for this specific area.

This parameter allows which cell or frame to be selected. Once a cell is 
selected, all Z axis parameters will only be valid for that cell.

Current, Start, and End Pos

These are the positional information of the rail or start or end postion. You 

can move the rail using keyboard or XBox 360 controller and/or set start and 

end positions.

Again, information specified are for the selected cell.

Count

This is number of images for the selected cell (frame) based on start and end 

position. 

Step Size

This is the step size for the Z axis and for ALL cells because it is determined 

by optical system specified in Stack tab, and therefore, it is not editable.

Distance

This is the distance from start and end positions for the selected cell (frame)

MoveTo Button
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This button move to X and Y rail to the position the selected cell cooresponds 

to. This is convenient because once in place in X and Y, it is easier to specify 

the stacking parameters (Z axis)

Stack Frame

This is the button that actually start stacking process for the selected cell. 

This is useful when this system is use for single axis stacking or when a cell 

needs to be restacked for whatever reason (failed flash, etc).

Discovery Of An Axis

Sometimes, for whatever reason, for example, forgot to power an axis up 

after connection is made. The tab for failed axis will be grayed out, but that 
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tab is still clickable. When the tab for the failed axis is selected, a button 

with Scan will appear, and now if that axis is confirmed to be connected, 

powered, clciking on Scan button will let system to discover the failed axis.

System Configuration

Stack Tab

Parameters on this page are related to timing. 

Wait

This specifies how long system should wait before taking a picture. This is 
important after the rail is moved -- system must let the whole setup to 
stablize and settle down after move but before taking a picture

Hold

This specifies how long system should delay before moving the rail This is 
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important when actual shutter is set to some long exposure time, system 
must wait till exposure is complete.

Snap

This is how long system should hold the shutter button down to take a 
picture. Note, this parameter is different from exposure time, this is the 
parameter to trigger camera to take a picture, essentially simulating a 
human pressing a shutter button

X, Y, and Z Tab

These parameters are used to setup motor, such as power, pitch and 
microstepping.

Reverse Direction

Sometimes, it is necessary to reverse direction of rail because of different 
setup configuration. By turning this option on, pressing UP arrow will move 
the rail in the direction opposite to default
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Power

This is the power level for selected motor when it is moving. If motor tends to 
stall, increase this value. But most of the time, this value should as little as 
possible to save motor life

Idle

This is the power level when motor is not moving for 10s, to save motor from 
idling with high current. However, for the Z axis, if a highly efficient rails is 
used, this value should be set to the same value as Power. 

And if motor tends to stall, particularly for the Z axis, this value should be 
set to same value as Power

Pitch

This is the pitch of lead screw used for the selected axis. For belt driven 
system, this is the value the belt travels for a full turn of motor. For example, 
if using MJKZZ XY table, this value is 40,000um (40mm).

Turns/Rev

This is the value for the selected motor, it should be number of steps motor 
turns a full revolution.

Micro Step

This is the value for step motor driver where each full step is further divided. 
For example, 32nd setting means each step is further divided into 32 micro 
steps.

For systems using external step motor driver, this value should match the 
value of the external driver setting. This is important because calculation of 
travel distance in absolute physical distance is based on this.

Important note, after changing parameters, they are not saved automatically 
because the changes could be temporary. To permenantly save the changes, 
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plese use menu File->Save.

Localizing This Application

This application can be localized to your own language if you wish. Under memu 
Help->Language->Export, a file will be generated containing all entries and words 
used in the application. Simply changing what is inside the double quote for every 
entry,save the file. Then use menu Help->Language->Import function to import your 
translated file, it will restart the application and that is it.

Saving and Loading Settings

Very often some system settings change according to type of work required. For 
example, sensor size might change when switching cameras; or magnification 
changes when switching lenses. However, setting the right parameters can be 
tedious. 

You can, however, save current setting to a file and later load it back in. To save 
current settings, select File->Save As.

To load an existing setting, it must be done before connection is made, just use 
File->Open

Calculator

There are five different calculators that essentially calculates step size based on 
different lens system. Step size calculation is based on circle of confusion and 
there is 20% safety margin applied.. Here are list of values for each sensor type:

⦁ APS (Canon), this is for most of Canon crop frame cameras, like 550D (T2i), 60D, 
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etc. 

⦁ APS (Nikon/Pentax/Sony), this is for most of other type of APS sensors, mostly 

used by Nikon, Pentax, or Sony, 

⦁ Full Frame, this is for all full frame cameras. 

⦁ Micro 4/3, this is mostly for Olympus, Panasonic cameras where Micro Four 

Third sensor is used.

All calculators will calculate magnification (in case it is provide, as in objective, it 
is simple taken from there), effective aperture, and step size.

Estimating Step Size when Microscop Objective is used.

This is to calculate step size when an objective is used. 

⦁ Objective NA -- this is the Numeric Aperture value, usually marked on the body 

of objective. 

⦁ Objective Magnification -- this is the magnification the objective is designed for 

when used according to its specification. If the objective is not used according 
to its specification, this should be the ACTUAL magnification in use. For 
example, a Mitutoyo 10X 0.28 and 200mm objective can be used with 180mm 
tube lens, in this case, the actual magnification is 180/200 * 10 = 9x

CloseUp Filter Lens System
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This calculator is used for a lens system when a close up filter is used on front of a 
primary lens -- it could be a normal lens, a zoom lens, or a macro lens (where 
Primary Lens Magnification can be very high, such a 1x). The calculation also take 
extension into consideration.

⦁ Dioptor Value -- this is the dioptor value of the closeup filter. Normally this is 

specified by closeup manufacture, usually in form of +1, +2, +3, +4, +8, +10, etc. 

⦁ When using multiple closeup filters, simply use the sum of all dioptor value for 

this entry.  In case this value is NOT specified, here is a list of commonly used 
closeup filter and their dioptor values. 

⦁ Primary Lens Focal Length -- this is the actual focal length used with the 

closeup filter. In case of zoom lens, enter the actually zoom value.

⦁ Primary Lens Magnification -- this is the actual magnification value for the 

primary lens. In case of the primary lens is a macro lens, be careful to use 
ACTUAL magnification -- most macro lens provides maximum magnification, 
for example 1x,  when focused to closest point. 

⦁ Extension Tube Length (mm) -- this when an extension tube is used in addition to 

closeup filter.. If no extension tube is used, simply enter zero
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⦁ F-Stop -- this is the aperture used on the primary lens. This will affect the 

effective aperture.

Lens With Extension

This calculator calculates a single lens on an optional extension tube. If a lens 
already has enough magnification power, such as Canon MP-E 65, and does not 
have extension tube added, simple enter zero for Extension Tube Length.

⦁ Primary Lens Focal Length -- the actual focal length for the lens, in case of a 

zoom lens, read it from the lens barrel.

⦁ Primary Lens Magnification -- this is the actual magnification used on the lens. 

In case of some macro lens, such as Canon MP-E 65, there are magnification 
marking on them.

⦁ Extension Tube Length (mm) -- this is the length of extension tube measured in 

millimeters. Important note, if you do not have an extension, set this value to 
zero. For example with Canon MP-E lens, very often you do not need extension 
tube and still have a magnification of 1 to 5X.

⦁ F-Stop -- this is the actual aperture used on the primary lens.
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Stacked Lenses

This calculator is for the lens system where two lenses are stacked together with 
one is reversed on another. Most often, the front lens (ie reversed lens) has shorter 
focal length and the primary lens has longer focal length.

⦁ Primary Lens Focal Length -- this is the actual focal length set on the primary 

lens, in case of zoom lens, it can be read from lens barrel

⦁ Reversed Lens Focal Length -- this is the focal length of reversed lens.

⦁ Optional Extension Tube Length -- this is option and if no extension tube is used, 

simply enter zero

⦁ F-Stop -- this is the aperture set on the reversed lens. In a stacked lenses 

system, it is better to set the primary lens to wide open and use the reversed 
lens to control aperture.

Reversed Lens

This calculator is for a system when a lens is reverse mounted on a bellow or 
extension tube. 
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⦁ Reversed Lens Focal Length -- this is the focal length of reversed lens

⦁ Reversed Lens Magnification -- this is the magnification of reversed lens, for a 

normal lens, it is usually very small.

⦁ Extension Tube Length -- this is the length of extension, can be extension tube 

or bellow. Note, this includes flange distance -- for Canon EOS camera, flange 
distance is 44mm and for Nikon AI mount, it is 39mm. So, if the actual extension 
tube length is 150mm, for Canon, the extension is 150+44 = 194mm.

F-Stop -- this is the aperture set on the reversed lens

FAQ

Q: After connection all components together and powering up, the rail is not 
moving, why?

A: Please press and hold LEFT SHIFT key and UP or DOWN key to set moving range 
whenever you power up the units.

Q: When I set number of steps and without changing the default step size 
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afterwards, the result is a little weird, why?

A: This is caused by integer division. Here is an example, assume the rail has 2mm 
pitch and motor micro step is 1/8, this result in 1.25um resolution for step size. Now 
say after setting start and end position for stacking, the total stacking distance is 
442um and then set number of steps to 80, this will result step size as 5um because 
the actual step size is 5.525um, but the next integer step size is 6.25um. However 
this 5um step size is not enough for the rail to reach the final 442um. The solution is 
to change the step size manual to 5um (click up and then down on the arrow next to 
Step Size), this will make the number of steps to be 89, 88 steps of size 5 and one 
step of size 2um to make a total of 442um

Q: When I set rail for stacking, I have reach the range limit of zero (0), so I extended 
this range by press and hold SHIFT key and DOWN arrow key, but then my start and 
end position changed, what happened?

A: When you extend the zero limit side of range, your stacking position becomes 
invalid. It is highly recommended to set range limit whenever you power up the 
motor and its driver unit to their max extend. Or whenever you change the range, 
re-position the rail for stacking.

Q: F6 and F5 to focus and stop focus is not working?

A: Only firmware with version 1.0 or above have this function
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